import re
regex = re.compile(r"(?:[ ]{4,}|\t{1,})(.+)", flags=re.MULTILINE)
test_str = ("This is a code block:\n\n"
" I need capturing along with\n"
" this line\n\n"
"This is a code fence below (to be ignored):\n\n"
"``` json\n"
"This must have three backticks\n"
"flanking it\n"
"```\n\n"
"I love `inline code` too but don't capture\n\n"
"and one more short code block:\n\n"
" Capture me\n"
" ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")