re = /(?:[ ]{4,}|\t{1,})(.+)/m
str = 'This is a code block:
I need capturing along with
this line
This is a code fence below (to be ignored):
``` json
This must have three backticks
flanking it
```
I love `inline code` too but don\'t capture
and one more short code block:
Capture me
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end