using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*(201710)[0-9]{2}.*$";
string input = @"ing_smac_process_data_full_20171025_csv
ing_smaci_process_data_delta_20171026_csv
ing_smaci_process_data_delta_20171027_csv
ing_smaci_process_data_delta_20171028_csv
ing_smaci_process_data_delta_20171029_csv
ing_smaci_process_data_delta_20171030_csv
ing_smaci_process_data_delta_20171031_csv
ing_smaci_process_data_delta_20171101_csv
ing_smaci_process_data_delta_20171102_csv";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}