use strict;
my $str = 'ing_smac_process_data_full_20171025_csv
ing_smaci_process_data_delta_20171026_csv
ing_smaci_process_data_delta_20171027_csv
ing_smaci_process_data_delta_20171028_csv
ing_smaci_process_data_delta_20171029_csv
ing_smaci_process_data_delta_20171030_csv
ing_smaci_process_data_delta_20171031_csv
ing_smaci_process_data_delta_20171101_csv
ing_smaci_process_data_delta_20171102_csv';
my $regex = qr/^.*(201710)[0-9]{2}.*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}