import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[A-Z1-9]*0+[A-Z1-9]|([A-Z0-9]{10})$)";
final String string = "ABC1000000\n"
+ "3212130000\n"
+ "0000000000\n"
+ "ABC1000100\n"
+ "0001000000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}