import re
regex = re.compile(r"^(?:[A-Z1-9]*0+[A-Z1-9]|([A-Z0-9]{10})$)", flags=re.MULTILINE)
test_str = ("ABC1000000\n"
"3212130000\n"
"0000000000\n"
"ABC1000100\n"
"0001000000")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")