use strict;
my $str = 'ABC1000000
3212130000
0000000000
ABC1000100
0001000000';
my $regex = qr/^(?:[A-Z1-9]*0+[A-Z1-9]|([A-Z0-9]{10})$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}