// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:[A-Z1-9]*0+[A-Z1-9]|([A-Z0-9]{10})$)").unwrap();
let string = "ABC1000000
3212130000
0000000000
ABC1000100
0001000000";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}