import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "src=\"([^\"]+)\"";
final String string = "<iframe src=\"https://docs.google.com/presentation/d/1jUSyTkZgZJbFIW6GrACmI67JnR51KKJUCqKUdjs_PuU/embed?start=true&loop=false&delayms=60000\" frameborder=\"0\" width=\"800\" height=\"479\" allowfullscreen=\"true\" mozallowfullscreen=\"true\" webkitallowfullscreen=\"true\"></iframe>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}