import Foundation
let pattern = #"src="([^"]+)""#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"<iframe src="https://docs.google.com/presentation/d/1jUSyTkZgZJbFIW6GrACmI67JnR51KKJUCqKUdjs_PuU/embed?start=true&loop=false&delayms=60000" frameborder="0" width="800" height="479" allowfullscreen="true" mozallowfullscreen="true" webkitallowfullscreen="true"></iframe>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}