import re
regex = re.compile(r"src=\"([^\"]+)\"", flags=re.IGNORECASE)
test_str = "<iframe src=\"https://docs.google.com/presentation/d/1jUSyTkZgZJbFIW6GrACmI67JnR51KKJUCqKUdjs_PuU/embed?start=true&loop=false&delayms=60000\" frameborder=\"0\" width=\"800\" height=\"479\" allowfullscreen=\"true\" mozallowfullscreen=\"true\" webkitallowfullscreen=\"true\"></iframe>"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")