const regex = /src="([^"]+)"/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('src="([^"]+)"', 'i')
const str = `<iframe src="https://docs.google.com/presentation/d/1jUSyTkZgZJbFIW6GrACmI67JnR51KKJUCqKUdjs_PuU/embed?start=true&loop=false&delayms=60000" frameborder="0" width="800" height="479" allowfullscreen="true" mozallowfullscreen="true" webkitallowfullscreen="true"></iframe>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}