using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([A-Z](?=\s)|[A-Z][^\.]$|\b[A-Z]\b$)";
string input = @"John A A Smith C.P.A.
John A A Smith C.P.A
Mr.
A A
John A
A
Smith
C.P.A.
P P
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}