import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z](?=\\s)|[A-Z][^\\.]$|\\b[A-Z]\\b$)";
final String string = "John A A Smith C.P.A.\n"
+ "John A A Smith C.P.A\n"
+ "Mr.\n"
+ "A A\n"
+ "John A\n"
+ "A\n"
+ "Smith\n"
+ "C.P.A.\n"
+ "P P\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}