const regex = /([A-Z](?=\s)|[A-Z][^\.]$|\b[A-Z]\b$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([A-Z](?=\\s)|[A-Z][^\\.]$|\\b[A-Z]\\b$)', 'gm')
const str = `John A A Smith C.P.A.
John A A Smith C.P.A
Mr.
A A
John A
A
Smith
C.P.A.
P P
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}