re = /([A-Z](?=\s)|[A-Z][^\.]$|\b[A-Z]\b$)/m
str = 'John A A Smith C.P.A.
John A A Smith C.P.A
Mr.
A A
John A
A
Smith
C.P.A.
P P
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end