#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)^(?!.*interessado: ).* CNPJ\W+(\d+\.\d+\.\d+\s?\/\d+-\s?\d+)"
Local $sString = "RECLAMADO: FOO LTDA - CNPJ: 99.999.999/9999-99" & @CRLF & _
"RECLAMADO: FOO FOO LTDA - CNPJ: 99.999.999/9999-99" & @CRLF & _
"TERCEIRO INTERESSADO: FOO FOO" & @CRLF & _
"TERCEIRO INTERESSADO: FOO FOO FOO FOO - CNPJ: 99.999.999/9999-99" & @CRLF & _
"TERCEIRO INTERESSADO: FOO FOO IT'S A TEST - CNPJ: 99.999.999/9999-99" & @CRLF & _
"TERCEIRO INTERESSADO: TEST" & @CRLF & _
"INTERESSADO: TEST - CNPJ: 99.999.999/9999-99"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")