# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?i)^(?!.*interessado: ).* CNPJ\W+(\d+\.\d+\.\d+\s?\/\d+-\s?\d+)"
test_str = ("RECLAMADO: FOO LTDA - CNPJ: 99.999.999/9999-99\n"
"RECLAMADO: FOO FOO LTDA - CNPJ: 99.999.999/9999-99\n"
"TERCEIRO INTERESSADO: FOO FOO\n"
"TERCEIRO INTERESSADO: FOO FOO FOO FOO - CNPJ: 99.999.999/9999-99\n"
"TERCEIRO INTERESSADO: FOO FOO IT'S A TEST - CNPJ: 99.999.999/9999-99\n"
"TERCEIRO INTERESSADO: TEST\n"
"INTERESSADO: TEST - CNPJ: 99.999.999/9999-99")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.