const regex = new RegExp('(?i)^(?!.*interessado: ).* CNPJ\\W+(\\d+\\.\\d+\\.\\d+\\s?\\/\\d+-\\s?\\d+)', 'gm')
const str = `RECLAMADO: FOO LTDA - CNPJ: 99.999.999/9999-99
RECLAMADO: FOO FOO LTDA - CNPJ: 99.999.999/9999-99
TERCEIRO INTERESSADO: FOO FOO
TERCEIRO INTERESSADO: FOO FOO FOO FOO - CNPJ: 99.999.999/9999-99
TERCEIRO INTERESSADO: FOO FOO IT'S A TEST - CNPJ: 99.999.999/9999-99
TERCEIRO INTERESSADO: TEST
INTERESSADO: TEST - CNPJ: 99.999.999/9999-99`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}