import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)^(?!.*interessado: ).* CNPJ\\W+(\\d+\\.\\d+\\.\\d+\\s?\\/\\d+-\\s?\\d+)";
final String string = "RECLAMADO: FOO LTDA - CNPJ: 99.999.999/9999-99\n"
+ "RECLAMADO: FOO FOO LTDA - CNPJ: 99.999.999/9999-99\n"
+ "TERCEIRO INTERESSADO: FOO FOO\n"
+ "TERCEIRO INTERESSADO: FOO FOO FOO FOO - CNPJ: 99.999.999/9999-99\n"
+ "TERCEIRO INTERESSADO: FOO FOO IT'S A TEST - CNPJ: 99.999.999/9999-99\n"
+ "TERCEIRO INTERESSADO: TEST\n"
+ "INTERESSADO: TEST - CNPJ: 99.999.999/9999-99";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}