import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"a\"[^\\}]*\"key\":\\s*(\\[[^\\}]*?\\]|\".*?\"|\\d+\\.*\\d*)";
final String string = "{ \n"
+ " \"a\": { \n"
+ " \"b\": { \n"
+ " \"c\": { \n"
+ " \"d\": \"v1\", \n"
+ " \"key\": \"v2\" \n"
+ " } \n"
+ " }, \n"
+ " \"c\": { \n"
+ " \"g\": \"v3\", \n"
+ " \"key\": \"v4\" \n"
+ " }, \n"
+ " \"key\": \"v5\" \n"
+ " } \n"
+ " } \n"
+ "} \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}