import re
regex = re.compile(r'"a"[^}]*"key":\s*(\[[^}]*?\]|".*?"|\d+\.*\d*)', flags=re.MULTILINE)
test_str = ("{ \n"
" \"a\": { \n"
" \"b\": { \n"
" \"c\": { \n"
" \"d\": \"v1\", \n"
" \"key\": \"v2\" \n"
" } \n"
" }, \n"
" \"c\": { \n"
" \"g\": \"v3\", \n"
" \"key\": \"v4\" \n"
" }, \n"
" \"key\": \"v5\" \n"
" } \n"
" } \n"
"} \n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")