// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)"a"[^}]*"key":\s*(\[[^}]*?\]|".*?"|\d+\.*\d*)"#).unwrap();
let string = "{
\"a\": {
\"b\": {
\"c\": {
\"d\": \"v1\",
\"key\": \"v2\"
}
},
\"c\": {
\"g\": \"v3\",
\"key\": \"v4\"
},
\"key\": \"v5\"
}
}
}
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}