$re = '/"a"[^}]*"key":\s*(\[[^}]*?\]|".*?"|\d+\.*\d*)/m';
$str = '{
"a": {
"b": {
"c": {
"d": "v1",
"key": "v2"
}
},
"c": {
"g": "v3",
"key": "v4"
},
"key": "v5"
}
}
}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);