#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\d+)\s*(?=((?!\)).)*\(|[^()]*$)"
Local $sString = "1Hello2Hai (in 2:3) 3hi 4 bye"
Local $sSubst = "\n$1 "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)