re = /(\d+)\s*(?=((?!\)).)*\(|[^()]*$)/
str = '1Hello2Hai (in 2:3) 3hi 4 bye'
subst = '\\n$1 '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result