$re = '/(\d+)\s*(?=((?!\)).)*\(|[^()]*$)/';
$str = '1Hello2Hai (in 2:3) 3hi 4 bye';
$subst = "\n$1 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;