package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<[\w\s_]+?%>)`)
var str = `< tr>< td>< img src=" < OI_IMAGE%>" width="50" height="35">< /td>< td>< NAME%>< /td>< td>< EMAIL%>< /td>< td>< DELIVERT_DATE%>< /td>< /tr>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}