re = /(<[\w\s_]+?%>)/
str = '< tr>< td>< img src=" < OI_IMAGE%>" width="50" height="35">< /td>< td>< NAME%>< /td>< td>< EMAIL%>< /td>< td>< DELIVERT_DATE%>< /td>< /tr>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end