// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(<[\w\s_]+?%>)").unwrap();
let string = "< tr>< td>< img src=\" < OI_IMAGE%>\" width=\"50\" height=\"35\">< /td>< td>< NAME%>< /td>< td>< EMAIL%>< /td>< td>< DELIVERT_DATE%>< /td>< /tr>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}