import re
regex = re.compile(r"(<[\w\s_]+?%>)")
test_str = "< tr>< td>< img src=\" < OI_IMAGE%>\" width=\"50\" height=\"35\">< /td>< td>< NAME%>< /td>< td>< EMAIL%>< /td>< td>< DELIVERT_DATE%>< /td>< /tr>"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")