#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)#@#@#@#@#@#@#@(?!.*?#@#@#@#@#@#@#@)(.*)$"
Local $sString = "#@#@#@#@#@#@#@ " & @CRLF & _
"Time:12:00 PM, CPU:12.0,RAM:12334321,Network:1231231233,...." & @CRLF & _
"#@#@#@#@#@#@#@" & @CRLF & _
"Time:12:01 PM, CPU:14.0,RAM:12354621,Network:1239864833,...." & @CRLF & _
"#@#@#@#@#@#@#@" & @CRLF & _
"Time:12:02 PM, CPU:9.0,RAM:12398781,Network:1231598697,...." & @CRLF & _
"#@#@#@#@#@#@#@" & @CRLF & _
"Time:12:02 PM, CPU:9.0,RAM:12398781,Network:1231598697,...." & @CRLF & _
"asasdas" & @CRLF & _
"dsa" & @CRLF & _
"d" & @CRLF & _
"" & @CRLF & _
"asd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")