re = /#@#@#@#@#@#@#@(?!.*?#@#@#@#@#@#@#@)(.*)$/
str = '#@#@#@#@#@#@#@
Time:12:00 PM, CPU:12.0,RAM:12334321,Network:1231231233,....
#@#@#@#@#@#@#@
Time:12:01 PM, CPU:14.0,RAM:12354621,Network:1239864833,....
#@#@#@#@#@#@#@
Time:12:02 PM, CPU:9.0,RAM:12398781,Network:1231598697,....
#@#@#@#@#@#@#@
Time:12:02 PM, CPU:9.0,RAM:12398781,Network:1231598697,....
asasdas
dsa
d
asd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end