import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "#@#@#@#@#@#@#@(?!.*?#@#@#@#@#@#@#@)(.*)$";
final String string = "#@#@#@#@#@#@#@ \n"
+ "Time:12:00 PM, CPU:12.0,RAM:12334321,Network:1231231233,....\n"
+ "#@#@#@#@#@#@#@\n"
+ "Time:12:01 PM, CPU:14.0,RAM:12354621,Network:1239864833,....\n"
+ "#@#@#@#@#@#@#@\n"
+ "Time:12:02 PM, CPU:9.0,RAM:12398781,Network:1231598697,....\n"
+ "#@#@#@#@#@#@#@\n"
+ "Time:12:02 PM, CPU:9.0,RAM:12398781,Network:1231598697,....\n"
+ "asasdas\n"
+ "dsa\n"
+ "d\n\n"
+ "asd";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}