import re
regex = re.compile(r"#@#@#@#@#@#@#@(?!.*?#@#@#@#@#@#@#@)(.*)$", flags=re.DOTALL)
test_str = ("#@#@#@#@#@#@#@ \n"
"Time:12:00 PM, CPU:12.0,RAM:12334321,Network:1231231233,....\n"
"#@#@#@#@#@#@#@\n"
"Time:12:01 PM, CPU:14.0,RAM:12354621,Network:1239864833,....\n"
"#@#@#@#@#@#@#@\n"
"Time:12:02 PM, CPU:9.0,RAM:12398781,Network:1231598697,....\n"
"#@#@#@#@#@#@#@\n"
"Time:12:02 PM, CPU:9.0,RAM:12398781,Network:1231598697,....\n"
"asasdas\n"
"dsa\n"
"d\n\n"
"asd")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")