#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?P<Given>\w+) ((?P<Initial>\w)\.? )*(?P<Family>\w+)$"
Local $sString = "Jack A. F. Smith" & @CRLF & _
                "Mary B. Miller" & @CRLF & _
                "Jack Taylor" & @CRLF & _
                "Pooface B. McGinginety"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
    _ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")