package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?P<Given>\w+) ((?P<Initial>\w)\.? )*(?P<Family>\w+)$`)
var str = `Jack A. F. Smith
Mary B. Miller
Jack Taylor
Pooface B. McGinginety`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}