$re = '/^(?P<Given>\w+) ((?P<Initial>\w)\.? )*(?P<Family>\w+)$/m';
$str = 'Jack A. F. Smith
Mary B. Miller
Jack Taylor
Pooface B. McGinginety';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);