import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<Given>\\w+) ((?P<Initial>\\w)\\.? )*(?P<Family>\\w+)$";
final String string = "Jack A. F. Smith\n"
+ "Mary B. Miller\n"
+ "Jack Taylor\n"
+ "Pooface B. McGinginety";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}