re = /(?:;)(.*\d)/
str = '<span class="amount">$1,286.58</span>
'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result