using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:\d\d;){2}\d+)";
string input = @"***01;01;283***;Póvoa do Vâle do Trigo;15315100 ***01;01;249***;Alcafaz;;;;;;;;;;;3750;011;AGADÃO ***01;01;2504***;Caselho;;;;;;;;;;;3750;012;AGADÃO _ ""15"" '' ghdhghg **AND IT CONTINUES**
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}