re = /((?:\d\d;){2}\d+)/
str = '***01;01;283***;Póvoa do Vâle do Trigo;15315100 ***01;01;249***;Alcafaz;;;;;;;;;;;3750;011;AGADÃO ***01;01;2504***;Caselho;;;;;;;;;;;3750;012;AGADÃO _ "15" \'\' ghdhghg **AND IT CONTINUES**
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end