const regex = /((?:\d\d;){2}\d+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?:\\d\\d;){2}\\d+)', 'g')
const str = `***01;01;283***;Póvoa do Vâle do Trigo;15315100 ***01;01;249***;Alcafaz;;;;;;;;;;;3750;011;AGADÃO ***01;01;2504***;Caselho;;;;;;;;;;;3750;012;AGADÃO _ "15" '' ghdhghg **AND IT CONTINUES**
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}