#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<a exist="(\d+)".*?<\/a> (is empty\.)|(?:you see (\d+) portions?.*?(It is full\.)?)$"
Local $sString = "The <a exist="99266047" noun="jar">glass jar</a> is empty." & @CRLF & _
"Inside the <a exist="102461739" noun="jar">glass jar</a> you see 20 portions of large grey pearls. It is full." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")