package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<a exist="(\d+)".*?<\/a> (is empty\.)|(?:you see (\d+) portions?.*?(It is full\.)?)$`)
var str = `The <a exist="99266047" noun="jar">glass jar</a> is empty.
Inside the <a exist="102461739" noun="jar">glass jar</a> you see 20 portions of large grey pearls. It is full.
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}