// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<a exist="(\d+)".*?<\/a> (is empty\.)|(?:you see (\d+) portions?.*?(It is full\.)?)$"#).unwrap();
let string = "The <a exist=\"99266047\" noun=\"jar\">glass jar</a> is empty.
Inside the <a exist=\"102461739\" noun=\"jar\">glass jar</a> you see 20 portions of large grey pearls. It is full.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}