re = /<a exist="(\d+)".*?<\/a> (is empty\.)|(?:you see (\d+) portions?.*?(It is full\.)?)$/
str = 'The <a exist="99266047" noun="jar">glass jar</a> is empty.
Inside the <a exist="102461739" noun="jar">glass jar</a> you see 20 portions of large grey pearls. It is full.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end