using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"#(?:\b[\s\S]*?\b#|\w+)";
string input = @"#The test# rain in #SPAIN stays mainly in the #plain";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}