re = /#(?:\b[\s\S]*?\b#|\w+)/
str = '#The test# rain in #SPAIN stays mainly in the #plain'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end