package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`#(?:\b[\s\S]*?\b#|\w+)`)
var str = `#The test# rain in #SPAIN stays mainly in the #plain`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}